Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: ABS Light on?

  1. #1
    Join Date
    Jul 2009
    Location
    Leeds
    Posts
    55

    ABS Light on?

    Happy New Year To ALL

    I wonder if anyone can help with regard to a light on my dash.

    I have two Yellow lights on my dash one says ABS and the other one is a warning '!' symbol.

    It still stops ok.

    Can anyone give any ideas to the problem?

    Could it be a pad low warning? Or brake fluid low? Or do the smarts suffer with ABS wires going faulty etc.

    Many Thanks in advance

    Richard

  2. #2
    Join Date
    Dec 2009
    Location
    Bangor, Co Down
    Posts
    2
    Hi! I feel your pain! The EXACT same thing is happening to my fortwo!

    Read my thread, hopefully it may help, you find it in the smartz tavern, Newbie needing help again!!

  3. #3
    Join Date
    Nov 2009
    Location
    Purley
    Posts
    126
    http://www.smartz.co.uk/showthread.php?t=11745 hopefully this will get you to nomi's thread.

    I've only had my Smart a month so can't make helpful comments but ABS warning lights are MOT failure points so you do need to get it sorted. I will paraphrase what I said on that thread and say I have NEVER had the ABS kick in on any car I've driven (other than deliberately) so under normal circumstances you won't notice an ABS failure.
    My name is Dave. I've got a named Kleine Calvin but you can call him Calvin Klein


  4. #4
    Join Date
    Jul 2009
    Location
    Leeds
    Posts
    55
    Thanks for thast chaps.
    Did you get your problem resolved? What was the problem on yours?
    Cheers
    Richard

  5. #5
    Join Date
    Jan 2009
    Location
    Norway
    Posts
    2,657
    Almost certainly a faulty brake switch....We had it on ours last winter due to wetness getting to it. Luckily, still under warrenty.

    http://www.evilution.co.uk/index.php?id=165

  6. #6
    Join Date
    Jan 2009
    Location
    Rugby
    Posts
    3,155
    Quote Originally Posted by Or_GazM View Post
    Almost certainly a faulty brake switch....We had it on ours last winter due to wetness getting to it. Luckily, still under warrenty.

    http://www.evilution.co.uk/index.php?id=165
    Except that the symptoms of a faulty brake switch are totally different.....http://www.fq101.co.uk/faq/459-my-br...t-in-gear.html

    OP - is it your trust+ light (orange triangle) or handbrake light (red circle) that's staying on with the ABS light??

    http://www.fq101.co.uk/faq/446-my-da...ats-wrong.html

    Either way, you'll need your codes read to find out exactly what's wrong, I notice you're in Leeds. Sam of forsmart is your nearest independant. He's mobile and comes highly recommended.

    Anastasia
    Mr Poo - 600cc Pulse
    Honky - 451 Passion Diesel



  7. #7
    Join Date
    Jul 2009
    Location
    Leeds
    Posts
    55
    Cheers Mr Poo
    It is definatly two Prange lights.
    One has a exclamation mark and the other has ABS on.
    They are not pemanantly on, but are on most of the time.
    I have Sam's phone number on my phone, I have not used him as yet but I will phone him on Monday when most people have gone back to work.
    Cheers
    Richard

  8. #8
    Join Date
    Jan 2009
    Location
    Rugby
    Posts
    3,155
    Quote Originally Posted by Ruby View Post
    Cheers Mr Poo
    It is definatly two Prange lights.
    One has a exclamation mark and the other has ABS on.
    They are not pemanantly on, but are on most of the time.
    I have Sam's phone number on my phone, I have not used him as yet but I will phone him on Monday when most people have gone back to work.
    Cheers
    Richard
    No worries, just tell him Stacey sent you
    It's your trust+ light that's on with your ABS, could be a number of things but the code reading machine (star) will tell you what's going on!

    Anastasia
    Mr Poo - 600cc Pulse
    Honky - 451 Passion Diesel



  9. #9
    Join Date
    Jan 2009
    Location
    Norway
    Posts
    2,657
    Quote Originally Posted by Ruby View Post
    Cheers Mr Poo
    It is definatly two Prange lights.
    One has a exclamation mark and the other has ABS on.
    They are not pemanantly on, but are on most of the time.

    Richard
    EXACTLY our symptoms....and it WAS just the brake switch

  10. #10
    Join Date
    Nov 2004
    Location
    , ,
    Posts
    1,964
    what I would do before laying out for potentially needless diagnostics is check three key related areas:

    They are ALL common problems on the smart and are better sorted sooner rather than later as they will almost certainly be happening to your car without you realising, so you are better off checking/confirming these areas anyway and cross them off the list of jobs that need looking at, regardless.

    Brake pedal switch - water leaks in down the loom feeding it and ruins the double switch. Open up the box and check condition.
    Reluctor rings - they rust and can fall off completely. visual inspection again
    Steering wheel (Only on 698 cars) can also fail. Last resort after checking the first two.

    okay, 4 items - check enough brake fluid in the reservoir

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •