Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Loss of power 2009 451CDI

  1. #21
    Join Date
    Jan 2016
    Location
    Somerset
    Posts
    7
    Ok well there is good news and not so good!!
    Prompted by replies and suggestions I have been in contact with Mercedes , not exactly the easiest of exercises but the end product is that although my car is re Sept 2009 it is in fact a 45bhp model not 54 !
    I can hear one or two of you shouting "don't you know your own car"
    Well I obviously don't
    Mind you the reg doc or any literature that I could find actually give this info.
    Mercedes looked my chassis number and reg number on their computer data base and found my car to be in a batch that are 45 bhp!
    So sorry to those that have wasted their time!
    Anyway the bad news is that the car lost power today and went into limp mode

    Reset by turning off then on the ignition

    As the car is not a DPF car so I am told the problem MAY relate to over boost perhaps the sensor or the waste gate staying shut or slightly open
    As you must know by now my tech knowledge is zero!

    So any thoughts
    Ta

  2. #22
    Join Date
    Nov 2007
    Location
    BANCHORY
    Posts
    3,018
    In that case you have a reliable Smart car worth hanging on to. Limp/ lack of power usually EGR or waste gate turbo over boost related. See a specialist and get it sorted.
    Drives a Smart Cdi - 65 to 85 MPG

  3. #23
    Join Date
    Jan 2016
    Location
    Somerset
    Posts
    7
    Quote Originally Posted by tolsen View Post
    In that case you have a reliable Smart car worth hanging on to. Limp/ lack of power usually EGR or waste gate turbo over boost related. See a specialist and get it sorted.
    Ok
    Just to took the car to Smart Stuff at Shepton Mallet, nice people.

    Computer threw a code P0105 The signal from component B5/1 (Charge pressure sensor) is implausible or no signal.
    Evidently needs a new sensor
    This requires dismantling the rear body panels and lights and sway bars to get to the sensor
    Hey ho
    Of course P0105 is associated with other problems
    Probably time to move the car on

  4. #24
    Join Date
    Nov 2007
    Location
    BANCHORY
    Posts
    3,018
    Quote Originally Posted by Bushy77 View Post
    Ok ...
    Probably time to move the car on
    Too early in my humble opinion.

    The turbo boost pressure sensor/ inlet manifold pressure sensor/ charge air pressure sensor B5/1 on your engine is at exactly same location as on my 2002 Smart Cabrio Cdi.

    Photo shows the 450 version of the diesel engine fitted in the 451.
    Boost pressure sensor is seen just to the right of inlet manifold and forward of rail pressure sensor. Boost pressure sensor is on a flexible rubber mount. It is connected to inlet manifold via a rubber hose which some times can come off.

    So no need to dismantle panels etc to got to the boost pressure sensor. You can access it wearing your best white shirt.

    No signal from boost pressure sensor could also be caused by chafing damage to wiring.
    Drives a Smart Cdi - 65 to 85 MPG

  5. #25
    Join Date
    Nov 2007
    Location
    BANCHORY
    Posts
    3,018
    Inlet manifold is the black rectangular box bearing markings "Smart cdi, Engineered by Mercedes Benz".

    Perhaps a good start is by unplugging connector plug to boost pressure sensor and inspect for possible water ingress, corrosion etc. A wee clean and drop of contact cleaner or penetration oil may be all that is required.
    Drives a Smart Cdi - 65 to 85 MPG

  6. #26
    Join Date
    Jan 2016
    Location
    Somerset
    Posts
    7
    Thanks so much
    I will contact Smart Stuff this morning and get them to comment
    Have a good day

  7. #27
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    27
    hi where is THE sensor B5/1 charge pressure sensor on the later cdi (2011 ) its not the one on the rear o/s cross member thats the pressure differential sensor (B28/8 )

  8. #28
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,135
    Quote Originally Posted by martininkent View Post
    hi where is THE sensor B5/1 charge pressure sensor on the later cdi (2011 ) its not the one on the rear o/s cross member thats the pressure differential sensor (B28/8 )
    I think it is the one under the big vacuum hoses in the centre of the engine towards the front of the car. It has vibration problems from the pipes touching it and there was a mod from Merc to stop the errors. IIRC.

    The problem is that there are loads of different names for things and no one seems quite sure on the 451.

    http://smartmaniacs.co.uk/forum/the-...ressure-sensor

    Does that help. It says not the one I thought but hay ho there you go.
    Last edited by Mjolinor; 30-04-2017 at 03:41 PM.

  9. #29
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    27
    hi yes I have just bought
    all 3 sensors, but I think maybe its wiring , so sensors first then the tracing back begins , I only have 4.1 v and it should be between 4.5v and 5.1v

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •