Results 1 to 4 of 4

Thread: Interior heater not working on high setting...

  1. #1
    Join Date
    Apr 2013
    Location
    Portsmouth
    Posts
    34

    Interior heater not working on high setting...

    Hi all,

    I got in my car this morning, turned the interior heater on... all good. Well, it's all good on the first 3 settings, but when i crank it up to the top setting, it cuts out completely!
    If i then switch it down a notch, its back to working again.

    Any ideas why it won't function on only the high setting? I assumed if it had packed up, no settings would work at all!

    Any thoughts?

    Thanks in advance people!

  2. #2
    Join Date
    Nov 2007
    Location
    BANCHORY
    Posts
    3,150
    Burnt contacts inside the switch so you either need a new switch or you open out your switch and clean its contacts. Not easy to get to though.
    Drives a Smart Cdi - 65 to 85 MPG

  3. #3
    Join Date
    Apr 2013
    Location
    Portsmouth
    Posts
    34
    Thanks for the reply - will check it out this weekend

  4. #4
    Join Date
    Mar 2010
    Location
    Hampshire
    Posts
    1,977
    Here is a guide for changing it:
    http://www.theroadster.net/trc/modul...cle.php?id=129

    That site (theroadster.net) is a better resource for you as a Roadster owner than this one.
    ==============================
    2004 Roadster-Coupe SB2 Brabus
    2005 ForTwo Brabus Numeric
    2014 Skoda Yeti 4x4 DSG
    ex 2002 City Coupe 600cc Pulse
    ex 2003 City Coupe 700cc Passion
    ==============================

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •