Page 1 of 7 123 ... LastLast
Results 1 to 10 of 61

Thread: 2010 cdi passion

  1. #1
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    49

    2010 cdi passion

    i have a 2010 that some garage has really messed up ( not smart ) they have messed up the pipe work (small pipes )for the egr and all other valves etc, I need a schematic diagram for these or a map of the pipes, theres joiners etc, any help welcome thanks

  2. #2
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,270
    As far as I have worked out.

    Vacuum pump, big pipe from right of engine to just near the right of the air filter box where it splits into 4 pipes.

    Big pipe disappears forward with a one way valve on, that is the brake servo.

    Three pipes remaining that go to three electrically operated vacuum switches

    One bolted to the side of the air filter box, that is the EGR solenoid so a pipe to that and then to the EGR itself just to the right of the air filter box bolted to the throttle body.
    One just behind the throttle body (towards the back of the car), output from that drops straight down and goes to a modulator just above the drive shaft slightly to the rear.
    One goes forward to a solenoid valve above the starter motor, the output from that comes back over the engine and goes to the turbo wastegate actuator.

    That is how mine is now. It was pretty much the same as yours when I got the car.

    Differential pressure sensor has two pipes going to it from the exhaust box. If you need more info about that then ask again.
    Last edited by Mjolinor; 22-04-2017 at 11:36 PM.

  3. #3
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    49
    hi mjolinor
    thanks for your reply,
    I believe the b5/1 sensor is on the rear bumper protection bar
    iam looking for a diagram really or photos so many routes and sensor plumbed up ,its a absolute mess,thanks or photos ,

  4. #4
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,270
    You will not find any pictures or diagrams. I Googled and asked and got nothing back. The differential pressure sensor is on the left under the back panel, you can see it through the holes under the boot lid. I put a new one on mine and didn't bother with that one at all. I mounted the new one on the left of the engine hole just behind the air filter. At under 30 it wasn't worth removing the back wing and you can get the plug off it without removing the wing.

    I can take pictures of mine if you want but they will not show you much, there is too much in there to see owt.

  5. #5
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    49
    hi mjolinor, well i have just replaced that one not that bad to do mate,, yep done, no different, still got no turbo boost, and only one error in mb star B5/1 charge pressure sensor,, even with just the ignition on, and code cleared, so its not a actual engine, running issue its present with just ignition on to me thats a electrical issue,
    where is b5/1,,also ignore the other codes I induced those ones
    Attached Images Attached Images
    Last edited by martininkent; 29-04-2017 at 06:06 PM.

  6. #6
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,270

  7. #7
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    49
    no seen those already, thats the early cdi version, this is 2011 diffenet setup, the sensor on the rear o/s bumper bar is the PRESSURE DIFFERENTIAL SENSOR (B28/8
    The one iam looking for is the B5/1 CHARGE PRESSUE SENSOR,,, I think its the one on the air box inlet pipe

  8. #8
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,270
    For sure it is not the one on the air filter box. THE differential pressure sensor will not affect boost, initially it will only cause errors in diagnostics but eventually if it is not working the exhaust will block completely and then it is new exhaust time.

    I will go and take a picture of mine, jsut hang on 15 minutes.

  9. #9
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,270

  10. #10
    Join Date
    Jan 2014
    Location
    hythe kent
    Posts
    49

    found sensor b5/1

    i disconect this sensor code goes,,, engine still no boost but i think this is the elusive B5/1,,,
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •