Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Sudden brake failure and then came back?

  1. #1
    Join Date
    Mar 2013
    Location
    London
    Posts
    13

    Sudden brake failure and then came back?

    Hi guys, today my brakes decided to not work as I was going down my road today which is on a hill. Luckily no one was around and straight after they decided to work again.

    Obviously now I don't trust the brakes but I have no clue on what it could be.

    Anyone have any idea what could of caused the problem as I'm worried it will happen again.

    Thanks!

  2. #2
    Join Date
    Jun 2015
    Location
    Somewhere on the Wirral
    Posts
    121
    When was the last time the callipers were changed? I wonder if the pistons in them got stuck..?

  3. #3
    Join Date
    Mar 2013
    Location
    London
    Posts
    13
    They haven't been changed to be honest. Should I replace them I've done 55k miles?

  4. #4
    Join Date
    Jun 2015
    Location
    Somewhere on the Wirral
    Posts
    121
    I would get the braking system checked out for safety sake anyway. Nothing leaking around the brake pipe joins that you can see (my 2002 450 had all 4 lines replaced and one of the nuts hadn't been tightened up properly which led to a squishy brake pedal with much reduced braking efficiency and the brake warning light appearing on the speedo)?
    Last edited by Ocracoke; 25-05-2017 at 03:02 PM.

  5. #5
    Join Date
    Apr 2009
    Location
    Ecosse
    Posts
    3,427
    Did the pedal go to the floor or was it solid?

    Petrol or diesel engine?

  6. #6
    Join Date
    Mar 2013
    Location
    London
    Posts
    13
    Quote Originally Posted by Ocracoke View Post
    I would get the braking system checked out for safety sake anyway. Nothing leaking around the brake pipe joins that you can see (my 2002 450 had all 4 lines replaced and one of the nuts hadn't been tightened up properly which led to a squishy brake pedal with much reduced braking efficiency and the brake warning light appearing on the speedo)?
    I'll get them checked over but I can't see any leaks or anything suspect. No lights on the dash either.

  7. #7
    Join Date
    Mar 2013
    Location
    London
    Posts
    13
    Quote Originally Posted by pinger View Post
    Did the pedal go to the floor or was it solid?

    Petrol or diesel engine?
    Hi it went all the way down and it's a petrol brabus 2008.

  8. #8
    Join Date
    Apr 2009
    Location
    Ecosse
    Posts
    3,427
    What is the fluid level in the reservoir?

  9. #9
    Join Date
    Mar 2012
    Location
    Burnley
    Posts
    1,161
    They do have independent brakes and "all the way down" should not be possible even if something fails.

    I had a weird one where sometimes the servo didn't work. This was a hole in the vacuum to the wastegate so when the wastegate was told to open I losta ll vacuum. This meant that the first time the brakes were applied if the wastegate was open then it worked properly but once the vacuum on the servo side of the one way valve ahd been used it was not replenished until the wastegate shut again.

  10. #10
    Join Date
    Mar 2013
    Location
    London
    Posts
    13
    Quote Originally Posted by pinger View Post
    What is the fluid level in the reservoir?
    Hi yeah this is the first thing I checked and the fluid level is the same between min and max.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •