Results 1 to 7 of 7

Thread: ESP and ABS lights stay on, and Hill Start Assist not working.

  1. #1
    Join Date
    Nov 2008
    Location
    ashton-under-lyne
    Posts
    5

    ESP and ABS lights stay on, and Hill Start Assist not working.

    On my 2012 For Two Cabrio (84) the ESP and ABS lights are not going off, and the Hill Start Assist is not working. Any ideas where the problem is (I don't have a fault reader)

  2. #2
    Join Date
    Oct 2009
    Location
    Bury Lancs
    Posts
    120
    My guess would be a wheel speed sensor on a wheel .....
    You need a code reader connected to determine the fault otherwise guessing will be very expensive
    An icarsoft i980 will talk to your car and can be had for under 100 ...... if you buy your own reader you'll have it for the next time ��
    Last edited by EmilysDad; 14-09-2017 at 02:14 PM.

  3. #3
    Join Date
    Nov 2008
    Location
    ashton-under-lyne
    Posts
    5
    Quote Originally Posted by EmilysDad View Post
    My guess would be a wheel speed sensor on a wheel .....
    Would it be a wheel speed sensor if the fault shows with the car stationary?

  4. #4
    Join Date
    Nov 2008
    Location
    ashton-under-lyne
    Posts
    5
    Quote Originally Posted by anotherbob View Post
    Would it be a wheel speed sensor if the fault shows with the car stationary?
    Fault code says ABS sensor faulty. Getting it replaced today.

  5. #5
    Join Date
    Oct 2009
    Location
    Bury Lancs
    Posts
    120
    Quote Originally Posted by anotherbob View Post
    Fault code says ABS sensor faulty. Getting it replaced today.
    Not too hard on the wallet I hope ��

  6. #6
    Join Date
    Nov 2008
    Location
    ashton-under-lyne
    Posts
    5
    Quote Originally Posted by EmilysDad View Post
    Not too hard on the wallet I hope ��
    145 inc. VAT.
    Sensor 38.40
    Diagnostics 50
    Labour 32.50
    VAT 24.18

    Presume there's a standard charge for Diagnostics, but if it only involves hooking up a laptop and reading results it seems a bit steep. However they must have invested a lot in the necessary hard and software. I'm content.

  7. #7
    Join Date
    Oct 2009
    Location
    Bury Lancs
    Posts
    120
    Quote Originally Posted by anotherbob View Post
    145 inc. VAT.
    Sensor 38.40
    Diagnostics 50
    Labour 32.50
    VAT 24.18

    Presume there's a standard charge for Diagnostics, but if it only involves hooking up a laptop and reading results it seems a bit steep. However they must have invested a lot in the necessary hard and software. I'm content.

    If it's any consolation I was recently charged 60 for diagnosis of a fault on my Merc .... it included a road test too.
    Not sure I even trust the 2500 diagnosis though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •