Results 1 to 6 of 6

Thread: How to check fault codes?

  1. #1
    Join Date
    Aug 2007
    Location
    Edinburgh
    Posts
    16

    How to check fault codes?

    Ok a few months ago when we 1st got our wee smart on her 1st long run she went into limp mode, after checking all the bits and bobs i found one of the turbo hoses was off so sorted that and reset, problem sorted.

    Well about 2 weeks ago long trip to the borders and she popped into limp mode again, so I thought it might be my fault I was playing with the gears and driving a bit aggressive so reset and thought nothing of it.

    This morning the other half took it to work 3miles and it jumped into limp mode again, now I’m going to check it all when she comes home but is there any way of reading the fault codes without taking it to smart, there are no warning lights or anything it’s just lost all the grunt.

    Any ideas?


    1999 LHD passion

  2. #2
    Join Date
    Oct 2006
    Location
    South West UK
    Posts
    164
    you may be able to get a back street garage to check it out but I'd imagine you'd be better going somewhere who knows what they're doing.

  3. #3
    Join Date
    Aug 2007
    Location
    Edinburgh
    Posts
    16
    I took it for a run to Edinburgh and back tonight about 30 mile round trip and she was fine untill half a mile from home when she went into limp again.

    I'm going to check the wastegate and pipes again just incase but if I can't find anything wrong I'll have to bite the bullit and get it checked.

    I did notice she was going high on the revs and holding onto the gears longer than normal, could the clutch cause her to go into limp?

  4. #4
    Join Date
    Jun 2006
    Location
    Falkirk
    Posts
    100
    I see you're in Edinburgh, why not get in touch with Sam at McSmarts; he's your best bet if you don't want to take your smartie to the dealer.

    Based in Airdrie and he has diagnostic software on his laptop, does remaps too
    Mr Rou

  5. #5
    Join Date
    Feb 2006
    Location
    SHEFFIELD
    Posts
    296
    definitely give sam at mcsmarts a call he'll be able to put it on diagnostics for you and tell you the fault and he doesn't charge a fortune either!!!
    Fi

  6. #6
    Join Date
    Aug 2007
    Location
    Edinburgh
    Posts
    16
    Hi all sorry for the delay

    Thanks for all the help after digging a bit I tried cleaning the wastegate and fitting a new clip and so far its been like driving a new car.

    Nice low rev gear chage and she goes into 6th at about 50mph now rather than 60mph


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •